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Functions 
SUM (x;y;...)  
   The function SUM() adds the different arguments.  

   To get the sum of a group of adjacent cells, you have to define the area as being an argument. The 
formula SUM(C2:C5) will add the contents of the cells C2, C3, C4 et C5.  

INT(x)  
   This function gives the integral value of x.  
   Example: =INT(14,57) gives 14  

SQRT(x) gives the square root of x.  

COS(x)  
   This functions gives the cosines of the angle x expressed in radians.  
   Example: =COS(PI()) gives -1  
 
REMARK :The angles taken as arguments in trigonometric functions have to be expressed in radians.

To convert an angle expressed in degrees, multiply it by Pi divided by 180.  
 
AVERAGE(x;y;...)  

   
This function gives the average of all arguments, which means the sum of the arguments divided 
by the number of arguments.  

   Example: =AVERAGE(12;-1;23;6;17) gives 11,4  

RATE(nper;pmt;pv;fr;type;guess)  
   This function calculates the final interest rate of a loaner.  
      nper represents the number of reimbursements.  
      pmt represents the amount payed per reimbursement (negative for a loaner).  
      pv represents the value to be reimbursed at the beginning.  
      fr represents the value at the end of the reimbursement. By default, fv is equal to 0.  

      type has to be equal to 1 if each reimbursement has to be paid at the end of the month or equal
to 0 if each reimbursement has to be paid at the beginning of the month.  

    

   Example:  For a loaner of 40 000 pounds over 4 years with monthly reimbursements of 2000 
pounds to be paid at the end of months,  

      RATE(48;-1000;40000;;1) gives 0,81% (monthly rate)  

TODAY() gives the current day.  

VALUE(text)  

   This function converts a text into numeric values. If the text contains non-numeric characters, it 
displays an error code.  

FIXED(number;decimals;no_commas)  

   This function converts a numeric value into a text. The argument decimals enables to determine 
the numbers of decimals to be converted.  

&  

   The operator & enables to chain characters strings and/or values. Example: "Country roads 
"&"take me home" gives: Country roads take me home. 

 
It is often useful to define a formula which applies to a cell a different contents according to the 
context.  
Example:  The table of Figure shows the activity report of a group of salereps. You can choose to 

affect a different comment whether they reached their objectives or not.  
   To do so, you have to define a conditional expression.  
The function to be used is: =IF(logical_test;value_if_true;value_if_false)  
The argument logical_test has to be a logical boolean value. The argument value_if_true
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represents the expression that will be used if the test is TRUE, value_if_false represents the 
expression that will be used if the test is FALSE.  
In our example, the expression to be entered in the cell E9 is:  
   =IF(C9>D9;" Target hit";"Lateness on target of ")  
Then you only have to copy this expression in the cells E10 to E13. (Figure)  

 
The arguments value_if_true and value_if_false can contain: constants (number or text), cell 
references, functions and other conditional expressions. Then you can emb up to 7 IF functions in 
one single formula.  

Logical operators:  
   x  >  y  True if x is bigger than y.  
   x  >=  y  True if x is bigger than or equal to y.  
   x  <  y  True if x is smaller than y.  
   x  <=  y  True if x is smaller than or equal to y.  
   x  <>  y  True if x is different from y.  
   x  =  y  True if x and y are equal.  

Logical functions:  

   AND(logical_1;logical_2;...)  
      This functions gives TRUE if all the arguments are TRUE.  
      Example: AND(2>1;4<>12;3<4) gives TRUE  

   OR(logical_1;logical_2;...)  
      This function gives TRUE if at least one argument is TRUE.  

   NOT(x) gives True if the argument is FALSE.  

   TRUE() always gives TRUE.  

   FALSE() always gives FALSE. 
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To display an entry message for a cell  
� Select the cell for which you want to display a message.  
� Select Validation... in the Data menu.   A dialog box appears.  
� Activate the Input Message card. (Figure)  
� Make sure that the box Show input message when cell is selected is marked.  
� In the text box Title:, enter the title of the message (it will be displayed in bold).  
� In the text box Input Message, enter the message.  

� Confirm with .    
The title and the message are immediately displayed when the cell is selected. (Figure) 

 
 

 
 
DEFINE ENTRY RECTRICTIONS  
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The best way to control the data entry is to fix conditions allowing only a certain type of entry. For 
example, you can limit the entry to integer numbers, to a chain of characters.... You can also create 
dropdown lists.  

  To define restrictions,  
  � Select the concerned cell.  
  � Select Validation... in the Data menu.  
     A dialog box appears.  

  

� Activate the Settings card. (Figure)  

     To limit the entry to numbers, texts, dates or times:  

        � Select between Whole number, Decimal, Date, Time or Text length in the dropdown list 
Allow:.  

        � Select the operator in the dropdown list Data:.  
           According to the selected operator, the content of the cell is different.  
        � Enter the comparison values.  

     To limit the filling of a cell to a list:  
        � Select List in the dropdown list Allow:.  
        � Activate the text box Source:.  
        � Select the cells of the calculation sheet containing the data previously entered.  

     � Confirm with .  

FILL RESTRICTED CELLS  

  Every value entered in a cell for which you have defined restrictions will be checked and rejected if 
the value is not valid. (Figure)  
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  For the cells containing a dropdown list, a little arrow appears at the right-hand side of the cell when 
it is selected.  

  
Once you have defined restrictions concerning the data entry  you can ask Excel to forbid any entry if 
the conditions are not respected, or to warn the user with a message.  
   � Select the concerned cell.  
   � Select Validation... in the Data menu. (Figure)  
      A dialog box appears.  
   � Activate the card Error Alert. (Figure)  
   � Make sure that Show error alert after invalid data is entered is activated.  

   � Select Stop, Warning or Information in the dropdown list Style: whether you want to stop the 
entry or warn the user.  

   � In the text box Title: enter the title of the message (it will be displayed in bold).  
   � Enter the message in the text box Error message:.  
According to your choice in the dropdown list Style: the warning message will be different:  
   

Stop:  

 

Page: 6 of 55 



Microsoft EXCEL (Advanced) 
By: http://emrause.blogspot.com 

Warning:  

 

Information:  

 
    
REMARK :

In the Data Validation dialog box, the button deletes the restrictions and 
the messages of the three cards. 
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The Outline Function 
 
The Outline function enables to organize calculation sheets containing a large amount of information. 
By dividing the sheet in detail rows (or columns) and in summary lines (or columns) of different levels, 
you can display or hide specific elements of the document to make the reading of information easier. 
  
When you create an outline, an area appears above the column header and on the left of the line 
headers.  
The outline symbols appear in this area for every line and for every column:  

 
    indicates a detailed column or row. (Figure a)  
    indicates a summary column or row of which the contents is hidden. (Figure b)  
    indicates a summary column or row of which the contents is displayed. (Figure c)  
 
In the symbol areas, in the prolongation of the row and column headers, level symbols appear: , 
, , ..., . They enable to identify rapidly the level of a summary row or column..  
 
To display or hide the outline symbol,  
   By using the menu:  
      � Select Options... in the Tools menu.  
         A dialog box appears.  
      � Activate the View card. (Figure)  
      � Mark or unmark the box Outline symbols. (Figure a)  

      � Confirm with . 
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Manual creation:   You can create an outline by defining a level for every row and column.  
 
This method is useful when the automatic creation does not recognize the summary rows or columns 
properly and generates a false outline. Automatic creation:   You can create an outline from a 
calculation sheet previously created.    
� Open the calculation sheet.    
� If the outline should concern only a part of the sheet, select the group of cells to be organized as 
an outline.    
� Select Group and Outline in the Data menu.     A submenu appears.    
� Select Auto Outline. (Figure)      
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Excel generates an outline on the basis of the formulas in your calculation sheets, to determine the 
level of the different rows and columns Outline styles:   When you generate an outline, particular 
styles (RowLevel_x and ColLevel_x) can be used for the formatting of the summary rows and 
columns.   If you want to use the outline styles, you have to let Excel know about it before you start 
the automatic creation.    
� Select Group and Outline in the Data menu.     A submenu appears.    
� Select Settings....     A dialog box appears. (Figure)    
� Mark the box Automatic styles. (Figure  a)    

� Confirm with .     or    

� Select to generate the outline immediately. 
 

 
 
You can modify the structure of an outline by creating groups or ungrouping them.  

To create a group:  
   To create a group of rows (or columns),  
   � Select the concerned rows or columns except the summary row or column. (Figure)  

   � 
Press simultaneously + + .  

      or
   � Select Group and Outline in the Data menu and Group... in the submenu. (Figure)  

Ungroup:  
   To ungroup a group of rows (or columns),  
   � Select the concerned rows or columns.  

   � 
Press simultaneously + + .  
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      or
   � Select Group and Outline in the Data menu and Ungroup... in the submenu.  
 
REMARK : 

If you create or dissociate groups frequently, you can use the tools and in the 
PivotTable toolbar.  

 
 

 
 

To delete an outline,  
� Select Group and Outline in the Data menu.  
   A submenu appears.  
� Select Clear Outline.  
   The different outline levels are deleted. If you have used the outline styles, they won't be deleted.  
 MINIMIZE THE DISPLAY   This manipulation enables to visualize only a group structure by hiding 
the detail rows and columns as well as the summary rows and columns of lower level. (Figure)    
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To minimize a group,      
� Click on the symbol in the summary row or column of the group. (Figure a)        
The whole group, except the summary row or column is immediately hidden. The symbol in the row 
or column becomes: .   To minimize the whole sheet to the summary rows or columns of a certain 
level,      
� Click on the symbol (or , , etc.) corresponding to the level you like. (Figure b)       
All details rows and columns, as well as summary rows and columns of lower level are hidden 
automatically.  
 
MAXIMIZE THE DISPLAY   This manipulation enables to display the elements of a group previously 
hidden.   To maximize a group,      
� Click on the symbol in the summary row or column of the group.       The whole group is 
immediately displayed. The symbol becomes: .    
 
To maximize the whole outline,      
� Click on the numbered symbol (or , , etc.) corresponding to the lowest level of the outline.   
    All the rows or columns of the sheet are immediately displayed again. (Figure) 
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The Lists 
 
EXCEL offers a simplified database manager system: the lists.  
You can use the lists to create a customer file, a personnel file, accounting... or any information 
system containing data of the same type.  
A list is the equivalent of a table in a database. It consists of fields (Figure) and records (Figure) which 
appear respectively in the columns and in the rows of the calculation sheet.  

The fields:  
   A field includes the elements of the same type of all listed records.  
   Example:  If you administrate an address file, you will create:  
         A field for the recipients' names  
         A field for their first names  
         A field for the street  
         A field for the postcode  
         A field for the town  
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   The field is characterized by its name.  
      Example: ZIP for the field that groups the postcodes.  
   And by its type of data: alphanumeric (text), numeric, date or time.  

The records (cards):  
   A card includes all information (of different types) refering to a given element.  

   Example:  If you have Mr WILSON James 12 EDEN Street 10000 NEW YORK, as a contact, his 
card will contain the following data:  

         WILSON (Name field)  
         James (First name field)  
         12 EDEN Street (Street field)  
         10000 (PC field)  
         NEW YORK (Town field)  
 
The List organization of these information will enable you to:  
   � to sort according to different criteria  
   � to find cards corresponding to one or several conditions  
   � to extract information matching with one or several criteria 
 
To create a list,  
� Enter the fields names in the 1st row (this row does not have to be the first row of the sheet), 

every column has to contain a field.  
� Enter the data of the first record in the second row.  
� If necessary, enter other records in the following rows.  
� Affect a different format to the field names as to the data of the list (font, attributes, borders, etc.) 

so that Excel can identify them.  
To add records to a list,  
� Activate one cell of the list.  
� Select Form... in the Data menu.  

   A dialog box appears (Figure). The field names are displayed in column on the left side of the 
dialog box along with the entry areas where the data of the first record appear.  

� Press + or + .  
   or
� 

Select .  
   An empty form appears.  
� Enter the data of the first field.  
� Press .  
   The cursor is positioned in the entry area of the second field.  
� Do the two last operations again for the following fields.  
� 

Press or select (or + ) to enter another record.  
   or
� 

Select to get back to the calculation sheet.  
 
REMARK : You can enter records directly in the calculation sheet at the end of the list. 
 
You can organize your list by using the options Form... of the Data menu.  
(Figure)  
By using it, you can:  
   � Enter records  
   � Modify records  
   � Delete records  
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   � Search  
When the form appears, the data of the first record are displayed.  

 
To reach a field:  
   � Press until you reach the field you like.  
      or
   � Press simultaneously and on the underlined letter of the field name.  

To reach a new record:  

   � 
Select .  

      or
   � Drag the cursor to the bottom of the vertical scroll bar. (Figure a)  
      or
   � Press + or + .  

To reach the first record:  
   � Drag the cursor to the top of the vertical scroll bar. (Figure b)  
      or
   � Press + or + .  

To reach the following record:  

   � 
Press or .  

      or
   � 

Select .  
      or
   � Click on the arrow of the vertical scroll bar.  
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To reach the previous record:  

   � 
Press or + .  

      or
   � 

Select .  
      or
   � Click on the arrow of the vertical scroll bar.  

 
 
To modify the contents of records, In the calculation sheet:    
� Activate the cell containing the data to be modified.      

� Press or click in the formula bar.      
� Modify the data. (Figure)      

� Confirm with .   or      
� Enter the new value directly in the cell.  
 
By using the form:    
� Select Form... in the Data menu.     A dialog box appears.    
� Activate the record to be modified  
� Position the cursor in the entry area of the field to be modified.    
� Modify the data.    

� Select . 
 
By using the form:    
� Select Form... in the Data menu.     A dialog box appears.    
� Activate the record to be deleted.    

� Select .     A warning dialog box appears.    
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� Confirm with and select to get back to the calculation sheet. In the 
calculation sheet:    
� Select the cell(s) to be deleted.    
� Select Delete... in the Edit menu or in the context menu. (Figure) 
 

 
 
GENERAL  

   You can create, in the list, fields containing of which the contents should be dependent on the other 
fields of the list.  

   Example:  In a list "Personnel salary", you can have fields like GROSS SALARY, CHARGES and 
NET SALARY.  

      The contents of NET SALARY will then depend on the contents of GROSS SALARY 
and CHARGES according to the formula:  

         NET SALARY = GROSS SALARY - CHARGES. (Figure a)  

  

 
The formulas of the computed fields are the same as those in a spreadsheet. You can use: 
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arithmetical operators, constants, functions, conditional expressions, etc...  

CREATE A COMPUTED FIELD  
  To define a computed field while creating the list,  
  � Enter the field name in the first row.  
  � Enter the values of the first row (except those of the computed field) on the next row.  
  � Position the cursor in the cell corresponding to the computed field.  
  � Press .  

  � 
Enter the formula and confirm with .  

  � Copy the formula in the existing records (cells below).  

  � Format the column (Currency format for example). The value of the computed field will appear 
formatted in the entry form.  

MODIFY A FORMULA 
  To modify the formula of a computed field,  
  � Activate the cell corresponding to the computed field of the first record.  
  � Modify the formula.  
  � Copy the formula into all the cells of the field of the list.  

DISPLAY OF A COMPUTED FIELD IN THE FORM  

  

When the list includes a computed field, this one appears in the form but can not be modified 
(Figure a)  

 

  When you enter a new record or modify an existing record, the formula is automatically updated 
whenever you activate another record.  
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Filters 
 
GENERAL  
   It is often useful to display the whole records of a list meeting one or more criteria.  

   For example, the list of all the customers of a town or those who haven't placed any order since a 
particular date, etc. You can use the filter to do so.  

AUTOMATIC FILTER  
   The automatic filter enables to define rapidly simple criteria.  
   To execute an automatic filter,  
   � Activate one cell of the database (of the worksheet).  
   � Select Filter in the Data menu.  
      A submenu appears.  
   � Select AutoFilter.  

      An arrow containing the fields names appears on the right of the cells. Click on this arrow to 
display a dropdown list.  

   � Activate the dropdown list corresponding to the field on which the filter will be based.  

      The dropdown list includes all the values used by this field in your list, as well as the options 
(All), (Top 10...), (Custom...), (Blanks) and (NonBlanks).  

   

� Select a value in the dropdown list.  

      Examples:  To find the records of the companies based in MADRID.  
            � Activate a cell of the list.  
            � Select Filter in the Data menu and AutoFilter in the submenu.  
            � Activate the dropdown list of the TOWN field.  
            � Select MADRID. (Figure)  
         To find in the list the records of the companies whose activity is unknown:  
            � Activate a cell of the list.  
            � Select Filter in the Data menu and AutoFilter in the submenu.  
            � Activate the dropdown list of the ACTIVITY field.  
            � Select (Blanks).  
    
REMARK :(Blanks) and (NonBlanks) are displayed in the dropdown list only if at least one cell of

the field is blank.  
 
      The search is executed and all records which do not correspond to the criteria are hidden. The 
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arrow of the dropdown list corresponding to the field on which the filter is based appears in blue, 
so do the row numbers of the list. A message indicating the number of records found appears in 
the status bar.  

   � If necessary, define another criteria for another field. In this case, only records meeting both 
criteria will be displayed.  

      Example:  To search in the list the records of the companies based in MADRID and offering 
SERVICES.  

         � Position the cursor in the list.  
         � Select AutoFilter in the Filter submenu of the Data menu.  
         � Activate the dropdown list of the TOWN field.  
         � Select MADRID.  
         � Activate the dropdown list of the ACTIVITY field.  
         � Select SERVICES.  
   

      Example:  To search in the list the records of the companies based in MADRID with an unknown 
activity:  

         � Position the cursor in the list.  
         � Select AutoFilter in the Filter submenu in the Data menu.  
         � Activate the dropdown list of the TOWN field.  
         � Select MADRID.  
         � Activate the dropdown list of the ACTIVITY field.  

         

� Select (NonBlanks).  

   To delete a criteria,  

      � Select (All) in the dropdown list corresponding to the field of which you want to delete the 
selection criteria.  

   To delete all criteria,  
      � Select Filter in the Data menu.  
         A submenu appears.  
      � Select Show All.  
         All the records of the list are displayed again.  

   To deactivate the automatic filter,  
      � Select Filter in the Data menu.  
      � Deactivate AutoFilter in the submenu.  
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AUTOMATIC CUSTOMIZED FILTER  

   The use of options provided by the dropdown lists of the automatic filters enable you to determine 
very quickly and easily the selection criteria of the records. However, the possibilities are still limited. 

   To select records according to more precise criteria, you can use the customized automatic 
filter.  

   

� Activate the automatic filter.  

   � Select (Custom...) in the dropdown list corresponding to the field to which the filter is applied.  
      A dialog box appears.  
   � Determine the criteria.  

   Example:  

To search in the list, the records of the companies based in NEW YORK or MADRID. 
(Figure)  

      � Activate the dropdown list of the TOWN field.  
      � Select (Custom...).  
         A dialog box appears.  
      � In the upper dropdown list , enter NEW YORK or select it in the list.  
      � Select Or. (Figure  a)  
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      � In the lower left dropdown list , select equals.  
      � In the lower right dropdown list , enter MADRID or select it in the list.  

      

� Confirm with .  

   Example:  To search in the list, the records of the companies having ordered between 1000 and 
2000 dollars. (Figure)  

      � Activate the dropdown list of the ORDER field.  
      � Select (Custom...).  
         A dialog box appears.  
      � In the upper left dropdown list, select is greater than or equal to.  
      � In the upper right dropdown list, enter 1000.  
      � Select And.  
      � In the lower left dropdown list, select is less than or equal to.  
      � In the lower right dropdown list, enter 2000.  

      

� Confirm with .  

 
REMARK :You can also use wildcard such as ? replacing one character or * replacing a group of 
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characters. 
Example: A* searches all words starting with A. 

 

 
GENERAL  

   Advanced filter enable to use complex criteria which cannot be defined by using the automatic 
filter.  

   When you apply an advanced filter, you can:  
      � filter in the list directly (as if using the automatic filter).  
      � extract the records meeting the criteria and create a new list with them.  
   Before using an advanced filter, you have to define a criteria box.  
 
CREATE A CRITERIA BOX  

   A criteria box consists of:  
      � a row in which the fields names are displayed. (Figure a)  
      � one or several rows figuring the extraction criteria. (Figure b)  
   � Select the fields names of the list.  

   � 
Select Copy in the Edit menu or click on .  

   � Activate an empty cell in your spreadsheet (above or on the right hand of the data list) or in 
another worksheet of the workbook.  

   � 
Select Paste in the Edit menu or click on or .  

   Criteria have to be entered above the fields they shall be affected to.  
   No empty row should be displayed in the criteria box.  

   Single criteria:  
      Example:  To display, in a list, the records of all the companies based in NEW YORK,  

         � Activate the cell in the criteria box, immediately below the cell containing the field 
TOWN.  

         � Enter NEW YORK. (Figure c)  

   Multiple criteria with AND operator:  

   If you want to select the records corresponding to several criteria, you have to define these criteria 
in the same row.  

      Example: To display in the list, the records of all the companies based in NEW YORK to which a 
minimum 10% is discount is granted, (Figure)  
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         � Enter NEW YORK in the cell immediately positioned below the field name TOWN.  
         � Enter >=0,1 in the cell immediately below the name DISCOUNT.  

      If you want to define several criteria in the same field, this field should be displayed twice in the 
criteria box.  

      Example  To display in the list, the records of the companies having ordered between 1000 and 
2000 dollars (Figure),  

         � Define a criteria box containing the field ORDER twice.  
         � Enter >1000 in the cell immediately above the first field name ORDER.  
         � Enter <2000 in the cell immediately below the first field name ORDER.  

   Multiple criteria with OR operator:  

      If you want to select records corresponding to at least one criteria among several ones, these 
criteria have to be displayed in distinct rows .  

      Example 1 To display in the list, the records of the companies based in NEW YORK or based in 
LOS ANGELES (Figure),  

         � Enter NEW YORK in the cell immediately below the field name TOWN.  
         � Enter LOS ANGELES below NEW YORK.  

      Example 2 To display in the list, the records of the companies based in LONDON or in the 
country ENGLAND,  

         � Enter LONDON in the cell immediately below the name TOWN.  
         � Go the row below and enter ENGLAND below the field name COUNTRY.  

   
 
Criteria including a "wildcard":  

      The "wildcard" ? and * are used to replace a character (?) or a group of characters (*) in an 
alphanumeric data.  

      Example:  To display in the list, the records of the companies situated in a town whose name 
starts with L,  

         � Enter L* in the cell below the field name TOWN.  

   
 
Computed criteria  

      
If the extraction criteria has to refer to a comparison between several fields or to the result of an 
operation including several fields, this criteria does not have to appear under a field name, but in 
a particular column, belonging to the criteria box.  

      Example: To display in the "Personnel" list, the records of all the salesmen whose turnover is 
greater than 10 times their salary,  
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         � In the criteria row, activate the column on the right of the last field.  
         � Press .  
         � Enter the reference of the cell corresponding to the T.O. field of the first record.  
         � Enter >10*.  
         � Enter the reference of the cell corresponding to the field SALARY of the first row.  

         � 
Confirm with .  

   Empty or filled fields:  
    Example 1 : To display in the list, the records of all the companies of which the activity is unknown, 

       

� Enter ="=" in the cell below the field name ACTIVITY. (Figure)  
 

      Example 2  : To display in the list, the records of all the companies of which the activity is 
known,  

         � Enter ="" in the cell below the field name ACTIVITY.  
 
EXECUTE FILTER  
   Once the criteria have been defined, you can execute the filter.  
   � Activate one cell of the list.  
   � Select Filter in the Data menu.  
      A submenu appears.  
   � Select Advanced Filter.... (Figure)  
      A dialog box appears. (Figure)  
   � In the Action area, select:  
      to display only the records corresponding to the criteria in the list.  
      or

      to execute an extraction, namely to create a new list containing only the 
records corresponding to the criteria.  
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   � In the List range: area, Excel automatically selects your list. If it is not the case, click directly in 
the calculation sheet and select the list.  

   � Activate Criteria range: and click in the calculation list or in the sheet containing the names of 
the copied fields and select the cells corresponding to the criteria box.  

      Your selection has to contain a row for the fields names and as many rows as defined criteria. Do 
not include any blank row in the selection.  

      If you have chosen to make an extraction,  

         � Activate the Copy to: area and click in the calculation sheet and activate the cell in which the 
new list will be displayed.  

   � Mark the box Unique records only if you do not want several identical rows to be displayed in 
the filtered list.  

   � Confirm with .  

   If you have chosen Filter the list, in-place the records which do not correspond to the criteria are 
hidden. To display all the records again:  

      � Select Filter in the Data menu.  
      � Select Show All in the submenu.  
  
Database Functions 
 
GENERAL  

   The database functions Database enable to execute statistical calculations on the records of the 
list.  

   These calculations are automatically updated when you make change in the list or in the criteria 
box.  

   Syntax:  
      All Database functions use the same syntax:  
         Function_name(Database;Field;Criteria)  

      where Database stands for the whole lists, Criteria the group of cells representing the criteria 
box and Field the column of the list on which the statistical calculation should be executed.  

ENTER A DATABASE FUNCTION 
   � Activate the cell where the function should be entered.  
   � Select Function... in the Insert menu.  
      or
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   � Click on in the formula bar.  
      A dialog box appears. (Figure)  

   

� Select Database (Figure a) in the dropdown list or select the category in the Or select 
acategory: area. (Figure b)  
 

   � Select the function in the list Select a function:.  

   

� Select , a new dialog box appears. (Figure)  
 

   
� Activate the Database area and click directly in the calculation sheet or use the button and 

select the list you like.  
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   � Activate the Field area and click in the calculation sheet on the name of the field on which the 
calculation should be executed.  

   � Activate the Criteria area and click in the calculation sheet and select the criteria box (see 
chapter advanced filters).  

      If there is no criteria box for this list, the Criteria area of the dialog box has to be filled anyway. 
In this case, select two empty cells of the same column.  

   � Select .  
 
REMARK :The calculation takes into account the whole records meeting the criteria. To execute a

statistic on all the records of the list, leave an empty row in the criteria box.  
 

   If you know the syntax of the database function, you can directly enter it in the cell without using 
the corresponding dialog box.  

THE DIFFERENT FUNCTIONS  

   DSTDEV  
      Calculates the standard deviation of a population sample.  

   DSTDEVP  
      Calculates the standard deviation of an entire population.  

   DGET  

      This function returns the field value if only one record corresponds to the criteria. Otherwise, 
it returns the error value #NUMBER!.  

   DMAX  
      Calculates the highest value.  

   DMIN  
      Calculates the lowest value.  

   DAVERAGE 
      Calculates the average of the data of records corresponding to the criteria.  

   DCOUNT 
      Calculates the number of records meeting the criteria.  

   DCOUNTA  
      Calculates the number of records meeting the criteria which field is not empty.  

   DPRODUCT  
      Multiplies the values of the field of the record meeting the criteria.  

   DSUM  
      Sums up the values of the field of the record meeting the criteria.  

   DVAR  
      Calculates the variation of a population sample.  

   DVARP  
      Calculates the variation of an entire population. 
 
 
AUTOMATIC SUBTOTALS 
 
GENERAL    
By using automatic subtotals, you can split up data groups in your list and insert statistical functions. 
You can insert subtotals in a list sorted before, or you can sort a list including subtotals.   When you 
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ask subtotals to be inserted, Excel automatically creates an outline which makes the manipulation of 
the list easier. CREATE   Before inserting subtotals, you have to sort the list by using the field on 
which the grouping should be executed as a sort key.    
� Activate a cell of the list.    
� Select Subtotals... in the Data menu. (Figure)      
A dialog box appears. (Figure)   
 

  
 

 
� In the dropdown list At each change in:, select the field to be subtotaled.  
(Figure a)    
� In the list Use function:, select one of the 11 functions. (Figure b)    
� In the Add subtotal to: area, mark the boxes corresponding to the fields for which you want to 
display the subtotals. (Figure c)    
� If there are already subtotals, mark the box Replace current subtotals to delete the previous 
functions and replace them by the new ones, or unmark the box to add the new functions to the 
existing ones.    
� Mark the box Page break between groups to print every group on a separate page. (Figure d)    
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� Mark the box Summary below data to display the subtotals below each group or unmark it to 
display the subtotals above the data groups.    

� Confirm with . DELETE   To delete subtotals,    
� Activate a cell of the list.    
� Select Subtotals... in the Data menu.     A dialog box appears.    

� Select . (Figure e) 
 
 
Pivot Tables 
 
Pivot tables are data analysis tools.  
On the basis of a list, you can perform statistics sorted by categories by using pivot tables. Pivot 
tables are updated automatically when the list they depend on is modified.  
A pivot table does not modify your list but uses its elements to build a new worksheet.  
Example:  You have created a list of marketing follow-up including the following fields:  
      NAME (Name of the salesrep)  
      REGION (Regional sales office the salesrep belongs to)  
      YEAR OF ENTRY  
      LEVEL OF STUDY  
      T.O. (Turnover)  
   To analyse the sales activity of the different regions, you want to create:  
      - a table showing the turnover (T.O.) classified by region and by education. (Figure)  
      - a table showing the average turnover (T.O.) by region and by year of entry. (Figure)  

      - a table showing the number of salesrep whose T.O. is higher than a certain amount, 
classified by education level.  
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   You can get all these elements very quickly by using pivot tables.  

 

Excel can create a pivot table on the basis of data from various sources, especially out of external 
applications.  
We will, however focus on pivot tables using data out of Excel sheets organized as a list, exclusively. 
 
To create a pivot table,  
� Open the sheet containing the list with which the pivot table should be created.  
� Activate a cell of the list.  
� Select PivotTable and PivotChart Report... in the Data menu.  
   The wizard PivotTable and PivotChart Wizard starts.  
   It consists of several dialog boxes which helps you step by step for the creation of pivot table.  
   A button bar is displayed at the bottom of each dialog box during all the creation procedure.  
   � Select:  

    to interrupt the creation procedure.  

    to get back to the previous step.  

Page: 31 of 55 



Microsoft EXCEL (Advanced) 
By: http://emrause.blogspot.com 

    to confirm the current step and go to the next one.  

    to start the table conception.  

   

Step n° 1 (Figure)  

      � Select Microsoft Excel list or database. (Figure a)  
      � Make sure that PivotTable is marked. (Figure b)  

      � 
Select .  

         You can also create a pivot table by using external data but we will only deal with Excel data.  
 

   

Step n° 2 (Figure)  

      Excel automatically detects the list and displays the references of the cell range.  

      � If necessary, modify them by clicking directly in the calculation sheet to select the concerned 
cells.  

      � 
Select .  
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Step n°3 (Figure)  

      
� In the Where do you want to put the PivotTable report? area, select the location of the 

pivot table. It can be an area of the calculation sheet from which the data are extracted, 
another sheet of the same workbook or another workbook.  

         By default, Excel uses a new sheet of the same worksheet.  
         Define the parameters of the pivot table:  

         � 
Click on . (Figure a)  

            A next dialog box appears. (Figure)  

            Each field of the list appears as a button on the right side of the dialog box. On the left, an 
illustration represents the future pivot table.  

            

To define row categories,  
 

               � Click on the button of the concerned field. (Figure a)  
               � Drag it to the ROW area. (Figure b)  

Page: 33 of 55 



Microsoft EXCEL (Advanced) 
By: http://emrause.blogspot.com 

               � Repeat the operation for every field you want to use as a row category.  
            To define column category,  
               � Click on the button of the concerned field and drag it to the COLUMN area. (Figure c) 

               � Repeat the operation for all other fields you want to use as column category.  
 

            To define page category (optional),  
               � Click on the button of the concerned field and drag it to the PAGE area. (Figure d)  

                  
If you use the PAGE area, the pivot table will display the data of one element at the 
same time of the selected field.  
 

            To define the data fields,  
               � Click on the button of the concerned field and drag it to the DATA area. (Figure e)  

                  By default, the wizard will suggest the sum of all values of the concerned records for 
numeric fields or the number of records for the alphanumeric fields.  

                 If you want to use another function (average, maximum, etc.),  
                 � Double-click on the button of the field in the DATA area.  

                    

A new dialog box appears. (Figure)  

                 � In the list Summarize by:, select a function.  

                 � Confirm with . (Figure a)  

         � Confirm with . (Figure b)  

         
 
To define the display options:  

            � 
Click on .  

            � Select the display options and confirm with .  

         � 
Select .  

            

Excel creates and displays the pivot table (Figure). The PivotTable toolbar appears along 
with a window PivotTable Field List if the active cell is in the pivot table. According to the 
complexity of the data to be operated and the number of records, the calculation step lasts 
more or less long.  
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a  Page field  

   Only the data corresponding to an element selected in the dropdown list are displayed in the pivot 
table.  

b  Field button  

   A field is the summary of information issued of the data source. Dragging a field button to a new 
area of the pivot table will be enough to organize the data differently.  

c  Element  

   An element is a subcategory of a field. Every element is displayed as a text box by row or by 
column, or in the list of the page field.  

d  Data of an element  
   The data of an element form the detail by row or by column of a field element.  

e  Summary data  

   They represent a summary of the data by using the functions SUM, AVERAGE, COUNT... or your 
own calculations.  

  
When you create a pivot table, a new toolbar appears. It consists of the following buttons:  
    Pivot table menu. (Figure)  
    Displays a dialog box containing automatic formats for the pivot table.  

    Creates a pivot chart.  

    Hides the detail rows or columns.  

    Displays the details rows or columns.  

    Executes the updating of the pivot table.  

    Includes the hidden elements in the subtotals.  

    Activates / deactivates the original display of the data.  

    Displays the Pivot table Field dialog box. Its content depends on the active cell.  

    Displays / hides the fields list. (Figure) 
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To modify the properties of the pivot table,  
� Position the active cell in the pivot table.    
 
By using the wizard:      

� Click on in the toolbar and select Wizard...        
or      
� Select PivotTable and PivotChart Report... in the Data menu.        
 
The wizard PivotTable and PivotChart Wizard starts.      
� Use the same procedure as for the creation.    
 
By using the PivotTable Field List window:      
This window enables to add a field in the pivot table without using the wizard.      
To do so,      

� Click on to display the window if not already displayed.      
� Click on one cell of the pivot table to display the window PivotTable Field List if not already the 
case.        
� Drag the button corresponding to the field toward the pivot table in the area that you like (column, 
row, data page).      
or        
� Click on the button corresponding to the field to be added in the window. (Figure a)        
� In the dropdown list, select the area to which you want to add the field. (Figure b)        

� Click on . 
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When you define a Page field, a dropdown list appears at the top of the pivot table , on the right of 
the Page field.  
� To limit the calculations of the pivot table to the data corresponding to a value, select the value in 
this list. (Figure)   or  
� Select (All) to take the whole list into account.  

� Click on . (Figure a)   Create a calculation sheet for each value of the Page field:      

 
� Select (All) in the dropdown list of the Page field.      

� Click on in the PivotTable toolbar and select Show Pages... in the list.      
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� In the dialog box, select the concerned field and confirm with .        
 
EXCEL generates a pivot table for each calculation sheet including only the data of an element of the 
Page field. Each sheet has the name of the element. 
 

 
 
A pivot table represents the values by categories. You can find at the intersection of a row category 
and a column category, either the number of concerned records, either a calculation on the values of 
these records but the details of the concerned records are not displayed.  
To know, by the combination of categories, the list of the records:  
� Double-click on the cell corresponding to the concerned categories.  
� Select in the dialog box, the field of which the detail is to be displayed and confirm with 

.  
  
The pivot charts 
The pivot charts enable you to represent a pivot table in the shape of a chart. Create a pivot chart 
from the list mode:    
 
� Position the active cell in the list from which the pivot chart should be created.    
� Select PivotTable and PivotChart Report... in the Data menu.      
 
The wizard PivotTable and PivotChart Wizard starts.    
� In the What kind of report do you want to create? area, select PivotChart report (with 
PivotTable report). (Figure a)    
� Use the same procedure as for the creation of a pivot table. Create a pivot chart from a pivot table: 
   
� Activate the sheet containing the pivot table.    
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� Click on in the PivotTable toolbar.    
 
Excel generates a new graph sheet. (Figure)    

 
 
The pivot table and chart are dependent on each other. Indeed, if you modify the chart, the table is 
modified accordingly and vice versa. Modify the display of a pivot chart:    
You can modify a pivot chart as any other Excel chart.    
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� Use the menus Format et Chart to define the different properties of the graph (colour, size, form, 
title, chart type, ...).  
 
 
Data tables 
 
Data tables enable to make simulations on the result of a formula.  
A data table consists of a table indicating the result of a formula according to the value of a parameter 
(single entry table) or 2 parameters (double entry table).  
  
To create a data table, you have to define:  
  � A formula.  
  � A list of values (in row or in column) to be used as formula parameters.  
Example:  
  You are looking for a salary method for a group of salesmen.  
  This salary has to consist of a fix part and a percentage of commissions on the sales.  

  Before defining the percentage, you want it to vary and observe its influence on the total amount of 
the salary.  

  

To do so, you can use a single entry table. (Figure)  

  � Define the formula by taking a example value for the percentage of the commission.  

     In our example, the salary (C4) correspond to the sum of the fix part (C1) and commissions (C2), 
which are calculated following the formula: T.O. (F2) X RATE(E2) / 100.  

  � In the cells below the salary, enter a list of values corresponding to the possible commission 
percentages.  

  � Select a group of cells containing the formula (C4) and the list of the values to be substituted to 
the percentage taken as an example. In our example, the range B4:C13.  

  � Select Table... in the Data menu. (Figure)  
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A dialog box appears. (Figure)  

  � Activate the Column input cell: area.  
  � Click in the calculation sheet on the value taken as an example for the percentages (E2).  

  � Confirm with .  

     Beneath every percentage of the list, a value corresponding to the result of the formula by using 
the respective percentage is shown.  

Tables with single entry by rows:  
  In our example, the entry values are shown by column.  
  We could also have shown them by row.  
  In this case, we would have used the Row input cell: area of the Table dialog box.  
  
Double entry tables use the same principle as the single entry tables. However, they enable to you to 
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vary 2 parameters of one formula.  
Example:  

  You are looking for a salary method for a group of salesmen consisting of a fix part and a 
commission calculated on the basis of 5% of sales.  

  You want to visualize the obtained salary depending on two parameters:  
     � The amount of the fix salary.  
     � The amount of sales.  

  

To do so, you can use a double entry table. (Figure)  

  � Define the formula by taking example values for the fix amount and the amount of sales (T.O.).  

     

In our example, the salary (C4) corresponds to the sum of the Fix (C1) and commissions (C2) 
(Figure), which are calculated according to the formula: T.O. (F2) X 5%.  

  � In the cells below the salary, enter a list of values corresponding to the different possible sales 
amounts.  
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  � In the cells on the right of the salary, enter a list of values corresponding to the possible fix 
amounts of the salary.  

  � Select a group of cells containing the formula (C4) and the list of the entered values. In our 
example, the range C4:G17.  

  � Select Table... in the Data menu.  

     

A dialog box appears. (Figure)  

  � Activate the Row input cell: area.  
  � Click in the calculation sheet on the value taken as an example for the fix amount (C1).  
  � Activate the Column input cell: area.  

  � Click in the calculation sheet on the value taken for example for the amount of the turnover T.O. 
(F2). (Figure)  

  � Click on .  
     A list of values is displayed.  

     

 
At the intersection of every value entered by row (fix amount) and the values entered by column 
(sales amount.), you can see the result of the formula (salary) corresponding to these two 
parameters.  

 
You can not delete the answer values of a data table one by one. They all have to be deleted in a 
single operation.  
� Select all the cells corresponding to the answer values of the data table. (Figure)  

� Press . 
 
A table with single or double entry is automatically updated. If you modify one entry value, the 
corresponding answer values are re-evaluated consequently. However, this systematic recalculation of 
the whole table after every modification in the calculation sheet can take quite long time when the 
tables are huge.  
 
To deactivate the automatic recalculation of the tables,    
� Select Options... in the Tools menu.      
A dialog box appears.    
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� Activate the card Calculation. (Figure)    
� In the Calculation area, select Automatic except tables. (Figure a)    

� Confirm with .      
 
The automatic recalculation is deactivated. However, the table will be recalculated whenever you 

press . 
 
 
The Goal Seek 
 
GENERAL  
   The Goal seek command enables to find out the component of a formula which result you know.  

   Excel successively tests several values for the variable component of the formula until it finds the 
appropriated result.  

USE  

   Define the different elements of the formula by using any value for the variable element of the 
formula  

   � Select Goal Seek... in the Tools menu, a dialog box appears.  
   � Activate the a Set cell: area.  
   � Click in the calculation sheet on the cell corresponding to the result of the formula.  
   � Activate the To value: area.  
   � Select the value you like as the result of the formula.  
   � Activate the By changing cell: area.  

   � Click on the cell corresponding to the variable element of the formula. This cell has to contain a 
value or be empty but can not contain a formula.  

   � Confirm with .  
      Excel is looking for the goal value and displays the Goal Seek Status dialog box.  

   � Select to accept the result.  
      or
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   � 
Select to restore the original values.  

   Example:  A quote has been damaged and you can not read the price per unit of the first item.  

      

� Rebuild the quote by using the known values and by recreating the formulas without 
taking care of their result. (Figure)  

      � Display the Goal Seek dialog box. (Figure)  
      � In Set cell:, enter the address of the total amount of the quote. (E13)  
      � In To value:, enter the total amount. (5300)  
      � In By changing cell:, enter the value of the missing price per unit. (D4)  

      � Confirm with .  
         Excel finds out the missing value nearly immediately.  
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VLOOKUP function 
 
The VLOOKUP function enables you to find an information in a table. This table is organized in rows, 
each row contains information about an element. The VLOOKUP function searchs vertically in the 1st 
column of the table the data entered by the user and returns the contents, situated in the same row, 
of the selected row as an argument in the VLOOKUP function. 
 
The table containing the information to be found has to be organized in rows. Each row represents a 
"record", it contains data relative to one element. The 1st cell of each row (the 1st column) contains 
the code of the row. It can be a numeric, alphanumeric or logical (true, false) code. The only 
constraint of this search table is that it should be sorted by ascending order of the first column. The 
table can be on another worksheet or in another workbook.  
 
Build the search table:    
� Replace the cells of the table, while keeping in mind that the 1st cell of each first row contains the 
code of the row.    
� Sort the table in ascending order on the 1st column of the table (The first column does not have to 
be the A column of the calculation sheet). (Figure)  
 

 
 
To name the table:    
To simplify the writting of the VLOOKUP function, it is recommended to name the search table.    
� Select the table containing all the information, excepted the 1st row if it contains the column 
headings.    
� Click in the Name Boxe area on the left of the formula bar and enter the name you like for the 
table search. (You can also use the menu Insert/Name/Define...) 
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The syntax of the VLOOKUP function is:  
=VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)  
 
   where:  - lookup_value is the address of the cell containing the data to be founded.  

      - Table_array is the name of the table or its references (data range). Excel compares
the argument Lookup_value with the values of the 1st column of this table.  

      - Col_index_num is the number n° of the column of Table_array containing the 
information to be displayed.  

� Enter in a cell (of the same sheet, of another sheet or another workbook) the data to be searched. 
(Figure a)  

� In another cell, enter the VLOOKUP function while paying attention to the 3 arguments mentioned 
above. (Figure b)  

   The function immediately returns the information situated in the column specified as the 3rd 
argument.  

   If the searched value is bigger than the last value of the 1st column of the table, the function 
returns the contents of the last row.  

   The function returns #N/A if the searched value is smaller than the 1st value of the 1st column or if 
the cell to be searched is empty.  

Example:  

   To make its quotes, a transpot company has created a search table containing on each 
row the information about customers, the 1st column containing the customers codes.  

   � Fill the table situated between the rows A14 and F18 as in Figure.  
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   � Select the range of cells A15:F18.  
   � Click in the Name Box area on the left of the formula bar.  

   � 
Enter Table as a name and press .  

   � Position the active cell in D2.  
   � Enter the following instruction: =VLOOKUP(D1 ;table ;2).  

   � 
Press to confirm.  

      The function returns #N/A because D1 is empty. (Figure)  
 

   � 
Position the cursor in D1, enter gar2 and press to confirm.  

      The VLOOKUP function is searching gar2 in the 1st column of table and displays the contents of 
the second cell of the same row.  

  
HLOOKUP function 
 
The HLOOKUP function can be used in the same way as the VLOOKUP function but HLOOKUP 
searches the data horizontally on the 1st row of the search table.  
The function is organized in columns, the 1st row represents the code of each column.  
The syntax of the HLOOKUP function is:  
= HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)  
 
   where:  - Lookup_value is the address containing the data to be found.  

      - Table_array is the name of the table or its references (data range). Excel compares
the argument Lookup_value with the values of the 1st row of this table.  

      - Row_index_num is the n° of the column of Table_array containing the information 
to be displayed.  
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Example:  

   

A sales director applies for each sales, a commission percentage as well as a bonus for the 
salesman. This percentage and the bonus are defined according to turnover sections T.O. The sales 
director decides to create a table containing on the 1st row the different sections of the turnover 
T.O, and on the following rows the commission percentages along with a bonus granted according 
to the amount of the turnover T.O.  

   � Enter on worksheet, the table situated between the cells B2 and J4 of Figure.  
   � Select the range C2:J4.  

   

� Click in the Name Box area on the left of the formula bar. (Figure a)  

   � 
Enter com and press to confirm.  

   � In C9, enter =IF($B9=0;"";HLOOKUP($B9;com;2)) and confirm.  
   � Copy cell C9 in D9 and modify the formula to get =IF($B9=0;"";HLOOKUP($B9;com;3))  
   � Select the range C9:E9 and copy it to 17 by using the copy handle.  
   � Fill the B column as shown in Figure 2.  

      If the value to be searched is between 2 values of the table, the HLOOKUP function (or VLOOKUP) 
returns the data corresponding to the beginning of the section.  

      Example: If the value to be searched is 25000, the % of the commission is 5%. 
 
The consolidation enables to create summary tables from source tables situated on the same sheet or 
on different sheets or workbooks. There are 2 consolidation methods:  
 
�The consolidation by category   The summary table is created from source tables having the 
same column, and/or row headings, but organized in a different order and with a different number of 
columns and rows.  
 
�The consolidation by position   The consolidation is executed by using source tables of which 
the information have the same position. This method does not take the column and row heading into 
account.  
 
Pivot tables can also be used to consolidate.  
 
CONSOLIDATE 
To generate the consolidation,  
� Create first the source tables on the same sheet or on different sheet or workbooks. (Figure)  
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� If you want to execute a consolidation by category, make sure that the column and row headings 
are the same (the way rows and columns as well as their number are organized is not important).  

� Activate the sheet where the summary table should be generated.  
� Position the active cell in the left upper corner of the table that you will generate.  
� Make sure there is no outline; in this case you have to delete it.  
� Make sure to have enough empty rows and columns to create the summary table. If it is not the 

case, Excel will replace these cells.  
� Select Consolidate... in the Data menu.  
   A dialog box appears.  
� In the dropdown list Function:, select the function you want to use to make the synthesis of the 

consolidated values (sum, average, etc.).  

   For each source table to be added to the consolidation:  
      � Click on on the right of Reference:.  
      � If the source table is situated in another sheet or in another workbook, activate them.  

      

� Select the source area while includinig the column and row headings if you want a 
consolidation by category. (Figure)  
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      � 
Press or click on on the right of the reference area. (Figure a)  

      � 
Click on .  

      � Use the same procedure for the other source areas to be added.  

   For a consolidation by position:  
      � Desactivate Top row and Left column in the Use labels in options frame.  

   For a consolidation by category:  

      

� Activate Top row and Left column in the options Use labels in frame. (Figure)  
 

   To link the summary with the source tables:  
      � Activate Create links to source data.  
� Confirm with .  

   
 
If you have linked the table with the sources, Excel automatically generates an outline enabling 
you to display or hide the detail of each row.  

  
Update a consolidation table linked to the sources:  
 
   Update the values,  

       
If you modify only the values of the source tables, the update is automatic  

   Update the table (if columns or rows have been added or deleted in the sources)  
      If you add or delete columns or rows in the sources table, you have to update the summary table. 

      Excel does not automatically updates the references of the source areas in the Consolidate dialog 
box.  

      Then you have to redefine the references of each modified source before you can 
 

generate a 
consolidation update. Make sure to delete the outline before.  

      � Select Group and Outline in the Data menu and Clear Outline. (Figure)  
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      � Position the active cell in the left upper corner of the summary table.  
      � Select Consolidate... in the Data menu.  
         A dialog box appears.  
      � Use the same procedure as for the creation of an unlinked table.  

Update an unlinked consolidation table:  
   Update the values  
      If you modify the value of a table, you have to update the consolidation table.  
      � Activate the sheet containing the summary table.  
      � Position the active cell in the left upper corner of the table.  
      � Select Consolidate... in the Data menu.  

         A dialog box appears. The whole parameters defined during the last consolidation are kept in the 
dialog box. (Figure)  

      � If necessary, add or modify the source areas (see next page).  

      

� If necessary, modify the parameters and confirm with to generate the consolidation 
again.  

Page: 52 of 55 



Microsoft EXCEL (Advanced) 
By: http://emrause.blogspot.com 

         The former data are replaced by the new ones.  
 

   Update the table (if columns or rows have been added or deleted in the sources)  
      If you add or delete columns or rows in the sources table, you have to update the summary table. 

      Excel does not automatically updates the references of the source areas in the Consolidate
dialog box.  

      Then you have to redefine the references of each modified source before you can generate a 
consolidation update. Make sure to delete the outline before..  

      � Position the active cell in the left upper corner of the summary table.  
      � Reach the Consolidate dialog box.  
      � In the list All references:, click on the source of which the references are to be redefined.  

      
� Click on on the left of the Reference text box: and use the same procedure as for a 

creation. (Figure)  
         Or
      � Modify directly its coordinates in the text box Reference:.  

      � 
Click on .  

         The new references are added to the list, the former ones are still valid. (Figure)  

      � 
Click on the former references and click on to delete them.  

      � If necessary, modify the parameters of the dialog box.  

      � Click on to generate the consolidation.  

Add a source area:  
   � Position the cursor on the left upper corner of the summary table.  
   � Select Consolidate... in the Data menu.  
      A dialog box appears.  
   � Click on on the right of the reference Reference:area.  
   � Activate the sheet or the workbook containing the source data.  

   � Select the source area while including the column and row headings if you want to execute a 
consolidation by category.  

   � 
Press or click on .  

   

� 
Click on . (Figure)  

   � If necessary, add another source area by using the same procedure.  
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   � Modify the parameters of the dialog box if you like (function, link,...).  

   � Confirm with to generate the summary table.  

Delete a source area:  
   � Reach the Consolidate dialog box after activating the upper left cell of the summary table.  

   
� In the list All references:  

click on the source data to be deleted.  
(Figure a)  

   � 
Click on . (Figure b)  

   
� If necessary, modify the parameters of the dialog box and click on to generate the 

consolidation, otherwise click on .  
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Additional notes: 


